VIRTUAL LOCAL AREA NETWORK (VLAN)

355 Views

Virtual local area network (VLAN) is a LAN that logically breaks a LAN is called a VLAN. VLAN increases Network performance, Broadcast reduces domain size, increases network security, increases network management and flexibility.

VLAN benefits and why used VLAN

One of the major benefits of using VLAN is to create a logical grouping of devices on the network. For example, a VLAN can be created for a project with the device used by those who work on it. Again VLAN can be made for any department. The advantage is that they do not have to be connected to the same switch nearby, Anywhere on the network, they can be grouped logically by VLAN.

Thus logically grouping gives VLAN another great advantage, it shortens the broadcast domain. Each VLAN serves as a broadcast domain. Broadcast messages go through the VLAN only when the entire network does not go to the broadcast message. This means that by making multiple VLANs on a larger network, limiting the broadcast can increase the performance of the network.

The benefits of using VLAN are briefly discussed:

Broadcast reduces domain size:

VLAN increases the number of broadcast domains and the decrease the domain size. As a result, the broadcast is restricted to VLANs, not just the entire network.

Increases network security:

VLAN allows network administrators to group switch ports for specific tasks. For example, you can build an engineering VLAN on devices used for the engineering department. Computers can determine which VLANs to connect to, depending on the ports they are connecting to. Again this can also be grouped based on the MAC (media access control) address of the device. Data frames sent from one of the computers in this group are limited to this VLAN. This is how VLAN enhances network security.

Network management and flexibility increase:

VLAN enables enhanced network management and network flexibility. VLAN can be managed from one central location. A host that is a member of a VLAN can also be controlled from one location. VLAN trunking protocol (VTP) and Inter VLAN routing allows access to network resources on a large network.

Increase network usage and efficiency:

Specifies which resources can be accessed from a VLAN. VLAN members will be able to access those resources. Also, the request for a resource is restricted to that VLAN only. The Marketing department request shall not unnecessarily disturb the Engineering department. Both the coalition and the broadcast networks work very efficiently.

VLAN ID

When multiple VLANs are configured on a switch, each VLAN is marked individually using a special number. This special number is called the VLAN ID.

i) Normal Range VLAN: For normal range VLAN, numbers from 1 to 1005 are used as VLAN IDs. 1 of these is the default VLAN which is configured by default in the switch and cannot be deleted/changed. And 1002 to 1005 these VLAN IDs are used as token ring and FDDI VLAN. In the case of a normal range VLAN, the VLAN configurations are in a VLAN database called VLAN. Dad is stored in the flash memory of the switch. Normally these normal range VLANs are used on a small or medium-sized network.

ii) Extended Range VLAN: For continued range VLAN, the numbers from 1006 to 4094 are used as VLAN IDs. Extended range VLANs are typically used on a large scale network. For extended-range VLANs, VLANs configurations are stored in the running configuration file of the switch.

Types of VLAN

i) Default VLAN: A default VLAN is created by default on Cisco switches using VLAN ID 1, this is called the default VLAN. This default VLAN cannot be deleted/modified. Considering network security, it is best not to use this default VLAN on production networks.

ii) Data VLAN: The data VLAN that users use to exchange data is called data VLAN. For normal-range VLANs 2 to 1001 these VLANs are used as data VLANs.

iii) Management VLAN: Management VLAN is a type of VLAN through which network management traffic such as CDP, Telnet, SSH, SNMP, etc. are exchanged. This management VLAN is used to keep management traffic separate and safe from general users’ traffic.

iv) Native VLAN: A large-scale VLAN transmits the traffic of multiple VLANs through a link between two switches on a base network, which is known as tagged traffic. Also, some of the non-VLAN traffic (Untagged) is transmitted through the link. For this reason, the two ports connected switch are configured as trunk ports. Their encapsulation is usually 802.1Q. 802.1Q trunk ports exchange untagged traffic via a Native VLAN. Any VLAN other than VLAN 1 in the production network should be used as a native VLAN.

Switchport Mode

Switch ports can be configured in two ways on a VLAN based network.

i) Access Port: An access port is a type of port through which one can transmit traffic to a VLAN. Usually, the end-user is connected to the network through this Access port.

ii) Trunk Port: Trunk port is a type of port through which two or more VLAN data can be transmitted. The ports that connect the two switches to the VLAN-based network are usually configured as trunk ports.

VLAN Trunks in Brief

A trunk is a point-to-point link between two switches through which multiple VLAN traffic can be accessed. Through this VLAN trunk, a network can be expended as needed. Cisco devise support IEEE 802.1Q encapsulation on its Fast Ethernet and Gigabit Ethernet ports.

Creating VLANs

The Cisco IOS command VLANs are used to create a VLAN on a Cisco switch. To this end, an ID of the VLAN is added. Any number between 2and 4094 can be used as a VLAN ID. You can then provide a name for that VLAN.

To create a VLAN on Switch, you can use the following commands as below:

Switch>enable

Switch# configuration terminal

Switch(config)#vlan 10

Switch(config-vlan)#name computer

Switch(config-vlan)#exit

Special Virtual local area network (VLAN)

Did know a little while ago that using VLAN as the ID of the number 2 to 4094 you can do. Why not use the ID here as ID? This is because this ID is associated with VLAN is known as a special VLAN called management Virtual Local Area Network or VLAN 1. This VLAN will be used for administrative purposes only. By default, VLAN 1 is already created on the Cisco switch and you cannot delete it. By default, all ports of the switch are members of this VLAN 1. When the VLAN in the new corner creates and assigns a pert there, then actually removes that port from VLAN 1 took over the VLAN.

For example, a VLAN network and configuration is shown:

VIRTUAL LOCAL AREA NETWORK (VLAN) configuration

Switch>          

Switch>enable

Switch# configuration terminal

Switch(config)#vlan 10

Switch(config-vlan)#name Electrical

Switch(config)#vlan 20

Switch(config-vlan)#name Computer

Switch(config-vlan)#exit

Switch(config)#interface vlan 10

Switch(config-if)#no shutdown

Switch(config-if)#ip address 192.168.10.1   255.255.255.0

Switch(config)#interface vlan 20

Switch(config-if)#no shutdown

Switch(config-if)#ip address 192.168.20.1   255.255.255.0

Switch(config)#interface range fastEthernet 0/1-2

Switch(config-if-range)#switchport access vlan 10

Switch(config)#interface range fastEthernet 0/3-4

Switch(config-if-range)#switchport access vlan 20

shows the default Virtual local area network (VLAN) configuration values:

Parameter Default Valid Values
VLAN ID 1 1-4094
VLAN name VLANx, where x is a number assigned by the software. No range
802.10 SAID 100,001 1-4,294,967,294
MTU size 1500 1500-18,190
Translational bridge 1 1002 0-1005
Translational bridge 2 1003 0-1005
VLAN state active active; suspend; shutdown

Hopefully, by watching this tutorial you will get some idea about VLANs basic theory and configuration. Be good.

Leave a Comment

Your email address will not be published. Required fields are marked *

This div height required for enabling the sticky sidebar